XenApp 7.6 Slow Logon Performance – Hotfix ICATS760WX64009

On a XenApp 7.6 shared Server OS desktop, there is considerable lag when users are logging in.  During logon, sessions seem to hang for a good number of seconds on a black screen prior to being given access to the desktop.

A simple way of improving slow logon performance on XenApp 7.6 shared desktop is to install Hotfix ICATS760WX64009.  This diminishes Interactive Session time by a few seconds.

Hotfix ICATS760WX64009 is not guaranteed to absolutely cure a slow logon but does help if you are on XenApp 7.6 and your VDA servers are running VDA Version 7.6.0.  The hotfix linked herein applies only to XenApp 7.6; XenDesktop 7.6 VDA Core Services for Windows Server OS (64-bit).

Hotfix ICATS760WX64009

If you want to further improve logon performance in XenApp 7.6 and not afraid to get dirty look into doing some of what this fellow Citrix Admin posted:

A few people have had problems here and I’ve ran into similar issues in the past few environments setup using 7.1, 7.5, and 7.6. I never faced these problems in XenApp 6.5. Since this is like my third go-round with this and using fully patched (7.6.1) with this build thought I’d post my workings.

Initial logon time with Citrix Policies, Group Policies, Logon Scripts: 280 s

Disable Antivirus: down to 40 s

Create Low-Risk policy, disable read/write scans of low-risk, add userprofilemanager.exe to low risk, re-enable antivirus: up to 67 s

Made exclusion to UPM Logs on top of regular citrix recommendations: down 45 s and also cleared mclogevent errors for long logon/logoff

Enabled legacy graphics mode: down 37 s

Disable Profile Streaming (fresh build, fresh roaming profiles, and highly configured exclusion list for appdata): 31 s

Delete key {2c7339cf-2b09-4501-b3f3-f3508c9228ed} from HKCU\software\Microsoft\active setup\installed components during logon which got time down to: 26 s ****This item drastically improved my RDP logins to the server****

Found errors in group policy processing, fixed issues causing errors so no more group policy warnings: 21 s

Full uninstall of receiver 4.0 and cleanup of registry/files per citrix article, reboot, install of 4.2: times down to 20 s for logon (before responsive desktop). ****This item also fixed my issues with COM1 port mapping for MICR printing in testing****

So, Citrix protocol is getting me into the server in about 20 seconds now and RDP protocol is getting me into the server in about 30 seconds. Don’t think I can ask for much more. Thanks for everyone’s findings and posts.

David

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s